Datalinklogger erkennt COM-Port nicht

Abstimmung des Motors
Antworten
Benutzeravatar
Erich
Beiträge: 33
Registriert: 24.12.2006, 15:40
Wohnort: Warstein

Datalinklogger erkennt COM-Port nicht

Beitrag von Erich » 03.06.2009, 07:33

Seit einigen Monaten erkennt mein Datalinklogger den COM-Port nicht mehr. :( Die Trijekt-Software dagegen läuft problemlos.
Mein Laptop hat natürlich (ist schließlich nicht aus der Steinzeit!) keine Serielle Schnittstelle mehr, sondern muss über einen USB-Adapter an die Trijekt angeschlossen werden.
Das hatte am Anfang auch immer funktioniert, aber jetzt aus unbekannten Gründen nicht mehr.
Ich habe den Logger einmal neu "drüberinstalliert", funktioniert trotzdem nicht.
Deshalb wollte ich ihn komplett deinstallieren, er ist aber in der Softwareliste nicht auzufinden.

Ich brauche den Logger jetzt schnell wieder, weil ich auf Einzeldrosselklappe umgestellt habe und auch neue Nockenwellen einbauen werde. Die Abstimmung auf der Straße wäre zu langwierig und für ein Gruppe H-Fahrzeug auch nicht unbedingt legal.

Wer kann weiterhelfen?

P.S.
Warum wird die Software eigentlich nur mit Serieller Schnittselle angeboten? Es gibt schon seit Jahren keine Laptops mehr zu kaufen, die eine haben. (zumindest kann man sie suchen wie die Nadel im Heuhaufen)
Langsam wäre es doch an der Zeit sich dem normalen Standar anzupassen :idea:

Benutzeravatar
Tobi
Site Admin
Beiträge: 2283
Registriert: 11.06.2007, 18:20

Beitrag von Tobi » 03.06.2009, 08:30

Hallo,

das ist merkürdig, dass win trijekt ihn erkennt und der Logger nicht...
Du musst unbedingt daran denken, dass immer nur ein Programm auf den Com-Port zugreifen darf. Bei Arbeiten mit dem Logger mindestens in win trijekt "online ein" abschalten, besser win trijekt ganz schließen.

Welcher USB-RS232-Adapter wird verwendet?
Wurde er in letzter Zeit mal ausgetauscht?
Wir empfehlen im Zweifelsfall immer den der Firma Conrad-Electronic, Art.: 982417
Damit gab es bislang an zig Laptops/PSs nie Probleme!
(Andere Adapter machen schonmal Schwierigkeiten)

Den Logger kann man nicht deinstallieren.
Er wird meines Wissens auch nirgendo in der Registry hinterlegt.
Wenn du ihn löschen möchtest, findest du ihn unter "C:\Programme\Datalinklogger".
Einfach das Verzeichnis löschen, dann isser weg.



gruß
Tobi

Benutzeravatar
Erich
Beiträge: 33
Registriert: 24.12.2006, 15:40
Wohnort: Warstein

Beitrag von Erich » 03.06.2009, 10:37

Trijekt schließe ich immer, bevor ich den Logger einschalte.
Wie gesagt, hat ja vor einem Jahr problemlos funktioniert, danach habe ich ihn nicht mehr gebraucht.

Der Adapter heißt PL-2303 USB-to-Serial. Von Conrad ist er nicht.

Ich werde ihn mal deinstallieren und neu aufspielen.



Warum verwendet man nicht den USB-Anschluss im Programm?
Damit wären alle Probleme aus der Welt.

Benutzeravatar
Tobi
Site Admin
Beiträge: 2283
Registriert: 11.06.2007, 18:20

Beitrag von Tobi » 03.06.2009, 12:06

Naja, also es gibt viele gute Gründe, die für RS232 sprechen.
Seit Jahren funktionierender Standard in der Industrie, problemlos größere Leitungslängen usw.

Zumal eine Änderung auf USB ja eine Hardwareänderung zur Folge hätte und du müsstest dann eine neue Steuerung kaufen ;-)


gruß
Tobi

Benutzeravatar
Erich
Beiträge: 33
Registriert: 24.12.2006, 15:40
Wohnort: Warstein

Beitrag von Erich » 03.06.2009, 12:57

Nee, ich will die "alte" behalten, die funktioniert sehr gut.

So, ich habe alles runtergeworfen und neu installiert.
Geht immer noch nicht.
Langsam bin ich mit meinem Latein am Ende.
Da baue ich lieber einen Motor auseinander und wieder zusammen, da sehe ich sofort, was ich mache und der funktioniert dann auch.

Aber wenn da nur so ein paar dusselige Elektronen durch die Leitungen flitzen, dann ist das wie im Stockdunkeln herumschrauben.
:cry:

Wat nu?

Benutzeravatar
Hermy
Beiträge: 973
Registriert: 30.11.2007, 23:49
Wohnort: Schwerin
Kontaktdaten:

Beitrag von Hermy » 03.06.2009, 21:42

Hallo

Schau mal mit beim Gerätemanager unter Kommunikationsanschluß welcher virtuelle Com-Port gewählt ist denn der Datalogger läuft nur unter Comport 1, der Trijekt ist es egal, da kann man ihn separat auswählen.

Mfg Kahnert

Benutzeravatar
Erich
Beiträge: 33
Registriert: 24.12.2006, 15:40
Wohnort: Warstein

Beitrag von Erich » 04.06.2009, 07:25

Im Gerätemanager find ich nix, was wie ein Kommunikationsanschluss aussieht.
Sorry, ich bin nicht unbedingt ein Computerexperte.
Wie finde ich das Teil genau und wie stelle ich das um?

Mein Trijekt-Programm läuft unter COM 3, das dürfte dann tatsächlich die Lösung sein.
Es kann aber sicher umgestellt werden, denn es lief ja mal...

Benutzeravatar
Tobi
Site Admin
Beiträge: 2283
Registriert: 11.06.2007, 18:20

Beitrag von Tobi » 04.06.2009, 11:53

Hey Hermy, sehr gute Idee!
Daran wird es sicherlich liegen!


Im Gerätemanager
=> Anschlüsse (Com und LPT)

Ich denke da müsste sowas oder was ähnliches stehn:
Prolific USB-to-Serial Comm Port (Com3)

Doppelklick darauf!
=> Anschlusseinstellungen
=> Erweitert
=> Com-Anschlussnummer
=> Com1 auswählen
=> OK
=> OK

alles schließen und mal Win-trijekt starten (diesmal auf COM1)
wenn das läuft, läuft auch der Logger.


gruß
Tobi

Benutzeravatar
Erich
Beiträge: 33
Registriert: 24.12.2006, 15:40
Wohnort: Warstein

Beitrag von Erich » 04.06.2009, 17:40

Das ist ja das Problem.
Danach habe ich schon gesucht, aber das gibt es nicht, sonst hätte ich es schon umgestellt.

Benutzeravatar
Tobi
Site Admin
Beiträge: 2283
Registriert: 11.06.2007, 18:20

Beitrag von Tobi » 04.06.2009, 19:18

also bei eingestecktem usb-adapter muss da irgendwo was mit com3 stehn...


gruß
Tobi

Benutzeravatar
Erich
Beiträge: 33
Registriert: 24.12.2006, 15:40
Wohnort: Warstein

Beitrag von Erich » 04.06.2009, 19:59

Heureka, wie der alte Grieche (war das nicht Archimedes?) sagte :idea:
Das wars.
Bei EINGESTECKTEM Kabel wird das Teil nur angezeigt.
Danke für den Tip, habs gefunden, auf COM 1 umgestellt und
LÄUFT :D :D :D
Jetzt wirds Motörchen richtig schnelle und die Konkurrenz blaß :twisted: :wink:

Antworten