CAN-Nachrichten enthalten keine Werte

Sonstige technische Fragen
Antworten
Florian R
Beiträge: 4
Registriert: 21.06.2012, 10:28

CAN-Nachrichten enthalten keine Werte

Beitrag von Florian R » 22.06.2012, 07:56

Hallo zusammen,

ich habe das T101 mal nur mit 12V versorgt und über "win triject" das auf Typ 2 und eine Baudrate von 500kbit/s eingestellt. Es sind noch keine Sensoren usw. angeschlossen. In "win triject" sehe ich nur die Batteriespannung und ein paar zufällige Spannungswerte.
Dann lese ich die CAN-Nachrichten über ein National Instruments cRIO mit einem 9853 CAN-Modul aus. Allerdings bekomme ich immer nur Nachrichten mit dem Identifier 0x0770, die keine Werte enthalten.
Auch wenn ich auf CAN-Bus-Protokoll Typ 1 umstelle enthalten die Nachrichten keine Werte.

Weiß jemand, woran das liegt? Wie kriege ich das Steuergerät dazu Werte zu senden?

Grüße

Florian R

Benutzeravatar
Tobi
Site Admin
Beiträge: 2384
Registriert: 11.06.2007, 18:20

Re: CAN-Nachrichten enthalten keine Werte

Beitrag von Tobi » 22.06.2012, 20:22

was für ne firmware (softwareversion) haste denn drauf?
5.xx ?

normalerweise wird da so allerhand geschickt, wenn der can eingeschaltet wird...

gruß
Tobi

Florian R
Beiträge: 4
Registriert: 21.06.2012, 10:28

Re: CAN-Nachrichten enthalten keine Werte

Beitrag von Florian R » 25.06.2012, 06:57

Die Firmware ist 5.36, Rev. 4.

Grüße

Florian

Florian R
Beiträge: 4
Registriert: 21.06.2012, 10:28

Re: CAN-Nachrichten enthalten keine Werte

Beitrag von Florian R » 25.06.2012, 15:18

Äh... sorry war wohl mein Fehler. D.h. es lag wahrscheinlich nicht am triject sondern am Auswerteprogramm in LabView. Jedenfalls funktioniert es jetzt ganz gut. Auch wenn ich noch nicht ganz nachvollziehen kann warum.

Jetzt habe ich noch eine Frage: Gibt es eine aktuellere Definition des AIM CAN-Protokolls als die Revision 5 vom Dezember 2009? Wenn ich nämlich den Batteriespannungswert entsprechend der Definition errechne, bekomme ich 24V statt 12V.

Schöne Grüße

Florian

Benutzeravatar
Tobi
Site Admin
Beiträge: 2384
Registriert: 11.06.2007, 18:20

Re: CAN-Nachrichten enthalten keine Werte

Beitrag von Tobi » 26.06.2012, 08:24

Achja, da ist ein Fehler in der Doku...


Hier ist es so, dass 5V dem Wert 1024 entsprechen.
Der ausgelesene Wert muss entsprechend umgerechnet werden.

Batteriespannung = "Canbus-Wert" * 5 / 1024

Beispiel:
10V = 2048 * 5 / 1024

Das heißt, wenn der Wert 2048 übertragen wird, sind das keine 20,48V sondern genau 10,0V.


gruß
Tobi

Florian R
Beiträge: 4
Registriert: 21.06.2012, 10:28

Re: CAN-Nachrichten enthalten keine Werte

Beitrag von Florian R » 26.06.2012, 09:24

Danke.

Und der Vollständigkeit halber: Die Kommunikation des triject mit dem NI CAN-Modul funktioniert nur, wenn letzteres NICHT als "listen only" konfiguriert ist.

So long

Florian

Antworten